image filter - preprocess

classic Classic list List threaded Threaded
10 messages Options
Reply | Threaded
Open this post in threaded view
|

image filter - preprocess

Desai Ankit
Hi all,

I am using package: imageFilters 

when I am runing the inbuild datasets like butterfly_vs_owl its works fine. 

but when I tried to load my images with same configuration as it was in inbuild dataset. it generate following error upon applying filter mentioned in error. (rather I tried all filters but its the same error that i get)

12:13:04: Command: weka.filters.unsupervised.instance.imagefilter.AutoColorCorrelogramFilter -D /path/to/folder/300_250_weka
12:13:09: Problem filtering instances: null

what could be the possible cause of this error?

Please help. 

Regads,
--

_______________________________________________
Wekalist mailing list
Send posts to: [hidden email]
List info and subscription status: https://list.waikato.ac.nz/mailman/listinfo/wekalist
List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html
Reply | Threaded
Open this post in threaded view
|

Re: image filter - preprocess

Eibe Frank-3
Have you checked the file paths in your ARFF file? Also, which file type are you using for your images?

Cheers,
Eibe

On Thu, 7 Sep 2017 at 12:22 AM, Desai Ankit <[hidden email]> wrote:
Hi all,

I am using package: imageFilters 

when I am runing the inbuild datasets like butterfly_vs_owl its works fine. 

but when I tried to load my images with same configuration as it was in inbuild dataset. it generate following error upon applying filter mentioned in error. (rather I tried all filters but its the same error that i get)

12:13:04: Command: weka.filters.unsupervised.instance.imagefilter.AutoColorCorrelogramFilter -D /path/to/folder/300_250_weka
12:13:09: Problem filtering instances: null

what could be the possible cause of this error?

Please help. 

Regads,
--
_______________________________________________
Wekalist mailing list
Send posts to: [hidden email]
List info and subscription status: https://list.waikato.ac.nz/mailman/listinfo/wekalist
List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html

_______________________________________________
Wekalist mailing list
Send posts to: [hidden email]
List info and subscription status: https://list.waikato.ac.nz/mailman/listinfo/wekalist
List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html
Reply | Threaded
Open this post in threaded view
|

Re: image filter - preprocess

Desai Ankit
All images are .jpg and arff file has two attributes first is filename as string and 2nd is numeric class. File path i have supplied as an argument -D option. 


On 07-Sep-2017 8:42 AM, "Eibe Frank" <[hidden email]> wrote:
Have you checked the file paths in your ARFF file? Also, which file type are you using for your images?

Cheers,
Eibe

On Thu, 7 Sep 2017 at 12:22 AM, Desai Ankit <[hidden email]> wrote:
Hi all,

I am using package: imageFilters 

when I am runing the inbuild datasets like butterfly_vs_owl its works fine. 

but when I tried to load my images with same configuration as it was in inbuild dataset. it generate following error upon applying filter mentioned in error. (rather I tried all filters but its the same error that i get)

12:13:04: Command: weka.filters.unsupervised.instance.imagefilter.AutoColorCorrelogramFilter -D /path/to/folder/300_250_weka
12:13:09: Problem filtering instances: null

what could be the possible cause of this error?

Please help. 

Regads,
--
_______________________________________________
Wekalist mailing list
Send posts to: [hidden email]
List info and subscription status: https://list.waikato.ac.nz/mailman/listinfo/wekalist
List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html

_______________________________________________
Wekalist mailing list
Send posts to: [hidden email]
List info and subscription status: https://list.waikato.ac.nz/mailman/listinfo/wekalist
List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html



_______________________________________________
Wekalist mailing list
Send posts to: [hidden email]
List info and subscription status: https://list.waikato.ac.nz/mailman/listinfo/wekalist
List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html
Reply | Threaded
Open this post in threaded view
|

Re: image filter - preprocess

Eibe Frank-3
Are their any other error messages in the log? Or in the console?

Cheers,
Eibe

On Thu, 7 Sep 2017 at 3:16 PM, Desai Ankit <[hidden email]> wrote:
All images are .jpg and arff file has two attributes first is filename as string and 2nd is numeric class. File path i have supplied as an argument -D option. 


On 07-Sep-2017 8:42 AM, "Eibe Frank" <[hidden email]> wrote:
Have you checked the file paths in your ARFF file? Also, which file type are you using for your images?

Cheers,
Eibe

On Thu, 7 Sep 2017 at 12:22 AM, Desai Ankit <[hidden email]> wrote:
Hi all,

I am using package: imageFilters 

when I am runing the inbuild datasets like butterfly_vs_owl its works fine. 

but when I tried to load my images with same configuration as it was in inbuild dataset. it generate following error upon applying filter mentioned in error. (rather I tried all filters but its the same error that i get)

12:13:04: Command: weka.filters.unsupervised.instance.imagefilter.AutoColorCorrelogramFilter -D /path/to/folder/300_250_weka
12:13:09: Problem filtering instances: null

what could be the possible cause of this error?

Please help. 

Regads,
--
_______________________________________________
Wekalist mailing list
Send posts to: [hidden email]
List info and subscription status: https://list.waikato.ac.nz/mailman/listinfo/wekalist
List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html

_______________________________________________
Wekalist mailing list
Send posts to: [hidden email]
List info and subscription status: https://list.waikato.ac.nz/mailman/listinfo/wekalist
List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html


_______________________________________________
Wekalist mailing list
Send posts to: [hidden email]
List info and subscription status: https://list.waikato.ac.nz/mailman/listinfo/wekalist
List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html

_______________________________________________
Wekalist mailing list
Send posts to: [hidden email]
List info and subscription status: https://list.waikato.ac.nz/mailman/listinfo/wekalist
List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html
Reply | Threaded
Open this post in threaded view
|

Re: image filter - preprocess

Desai Ankit
No. 

On 07-Sep-2017 8:53 AM, "Eibe Frank" <[hidden email]> wrote:
Are their any other error messages in the log? Or in the console?

Cheers,
Eibe

On Thu, 7 Sep 2017 at 3:16 PM, Desai Ankit <[hidden email]> wrote:
All images are .jpg and arff file has two attributes first is filename as string and 2nd is numeric class. File path i have supplied as an argument -D option. 


On 07-Sep-2017 8:42 AM, "Eibe Frank" <[hidden email]> wrote:
Have you checked the file paths in your ARFF file? Also, which file type are you using for your images?

Cheers,
Eibe

On Thu, 7 Sep 2017 at 12:22 AM, Desai Ankit <[hidden email]> wrote:
Hi all,

I am using package: imageFilters 

when I am runing the inbuild datasets like butterfly_vs_owl its works fine. 

but when I tried to load my images with same configuration as it was in inbuild dataset. it generate following error upon applying filter mentioned in error. (rather I tried all filters but its the same error that i get)

12:13:04: Command: weka.filters.unsupervised.instance.imagefilter.AutoColorCorrelogramFilter -D /path/to/folder/300_250_weka
12:13:09: Problem filtering instances: null

what could be the possible cause of this error?

Please help. 

Regads,
--
_______________________________________________
Wekalist mailing list
Send posts to: [hidden email]
List info and subscription status: https://list.waikato.ac.nz/mailman/listinfo/wekalist
List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html

_______________________________________________
Wekalist mailing list
Send posts to: [hidden email]
List info and subscription status: https://list.waikato.ac.nz/mailman/listinfo/wekalist
List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html


_______________________________________________
Wekalist mailing list
Send posts to: [hidden email]
List info and subscription status: https://list.waikato.ac.nz/mailman/listinfo/wekalist
List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html

_______________________________________________
Wekalist mailing list
Send posts to: [hidden email]
List info and subscription status: https://list.waikato.ac.nz/mailman/listinfo/wekalist
List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html


_______________________________________________
Wekalist mailing list
Send posts to: [hidden email]
List info and subscription status: https://list.waikato.ac.nz/mailman/listinfo/wekalist
List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html
Reply | Threaded
Open this post in threaded view
|

Re: image filter - preprocess

Eibe Frank-3
Not sure what's going on. You may have to try to debug this yourself.

Cheers,
Eibe

On Thu, 7 Sep 2017 at 3:24 PM, Desai Ankit <[hidden email]> wrote:
No. 

On 07-Sep-2017 8:53 AM, "Eibe Frank" <[hidden email]> wrote:
Are their any other error messages in the log? Or in the console?

Cheers,
Eibe

On Thu, 7 Sep 2017 at 3:16 PM, Desai Ankit <[hidden email]> wrote:
All images are .jpg and arff file has two attributes first is filename as string and 2nd is numeric class. File path i have supplied as an argument -D option. 


On 07-Sep-2017 8:42 AM, "Eibe Frank" <[hidden email]> wrote:
Have you checked the file paths in your ARFF file? Also, which file type are you using for your images?

Cheers,
Eibe

On Thu, 7 Sep 2017 at 12:22 AM, Desai Ankit <[hidden email]> wrote:
Hi all,

I am using package: imageFilters 

when I am runing the inbuild datasets like butterfly_vs_owl its works fine. 

but when I tried to load my images with same configuration as it was in inbuild dataset. it generate following error upon applying filter mentioned in error. (rather I tried all filters but its the same error that i get)

12:13:04: Command: weka.filters.unsupervised.instance.imagefilter.AutoColorCorrelogramFilter -D /path/to/folder/300_250_weka
12:13:09: Problem filtering instances: null

what could be the possible cause of this error?

Please help. 

Regads,
--
_______________________________________________
Wekalist mailing list
Send posts to: [hidden email]
List info and subscription status: https://list.waikato.ac.nz/mailman/listinfo/wekalist
List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html

_______________________________________________
Wekalist mailing list
Send posts to: [hidden email]
List info and subscription status: https://list.waikato.ac.nz/mailman/listinfo/wekalist
List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html


_______________________________________________
Wekalist mailing list
Send posts to: [hidden email]
List info and subscription status: https://list.waikato.ac.nz/mailman/listinfo/wekalist
List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html

_______________________________________________
Wekalist mailing list
Send posts to: [hidden email]
List info and subscription status: https://list.waikato.ac.nz/mailman/listinfo/wekalist
List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html

_______________________________________________
Wekalist mailing list
Send posts to: [hidden email]
List info and subscription status: https://list.waikato.ac.nz/mailman/listinfo/wekalist
List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html

_______________________________________________
Wekalist mailing list
Send posts to: [hidden email]
List info and subscription status: https://list.waikato.ac.nz/mailman/listinfo/wekalist
List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html
Reply | Threaded
Open this post in threaded view
|

Re: image filter - preprocess

Desai Ankit
Can we supply filepath in place of filename? In arff? 

On 07-Sep-2017 8:56 AM, "Eibe Frank" <[hidden email]> wrote:
Not sure what's going on. You may have to try to debug this yourself.

Cheers,
Eibe

On Thu, 7 Sep 2017 at 3:24 PM, Desai Ankit <[hidden email]> wrote:
No. 

On 07-Sep-2017 8:53 AM, "Eibe Frank" <[hidden email]> wrote:
Are their any other error messages in the log? Or in the console?

Cheers,
Eibe

On Thu, 7 Sep 2017 at 3:16 PM, Desai Ankit <[hidden email]> wrote:
All images are .jpg and arff file has two attributes first is filename as string and 2nd is numeric class. File path i have supplied as an argument -D option. 


On 07-Sep-2017 8:42 AM, "Eibe Frank" <[hidden email]> wrote:
Have you checked the file paths in your ARFF file? Also, which file type are you using for your images?

Cheers,
Eibe

On Thu, 7 Sep 2017 at 12:22 AM, Desai Ankit <[hidden email]> wrote:
Hi all,

I am using package: imageFilters 

when I am runing the inbuild datasets like butterfly_vs_owl its works fine. 

but when I tried to load my images with same configuration as it was in inbuild dataset. it generate following error upon applying filter mentioned in error. (rather I tried all filters but its the same error that i get)

12:13:04: Command: weka.filters.unsupervised.instance.imagefilter.AutoColorCorrelogramFilter -D /path/to/folder/300_250_weka
12:13:09: Problem filtering instances: null

what could be the possible cause of this error?

Please help. 

Regads,
--
_______________________________________________
Wekalist mailing list
Send posts to: [hidden email]
List info and subscription status: https://list.waikato.ac.nz/mailman/listinfo/wekalist
List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html

_______________________________________________
Wekalist mailing list
Send posts to: [hidden email]
List info and subscription status: https://list.waikato.ac.nz/mailman/listinfo/wekalist
List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html


_______________________________________________
Wekalist mailing list
Send posts to: [hidden email]
List info and subscription status: https://list.waikato.ac.nz/mailman/listinfo/wekalist
List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html

_______________________________________________
Wekalist mailing list
Send posts to: [hidden email]
List info and subscription status: https://list.waikato.ac.nz/mailman/listinfo/wekalist
List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html

_______________________________________________
Wekalist mailing list
Send posts to: [hidden email]
List info and subscription status: https://list.waikato.ac.nz/mailman/listinfo/wekalist
List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html

_______________________________________________
Wekalist mailing list
Send posts to: [hidden email]
List info and subscription status: https://list.waikato.ac.nz/mailman/listinfo/wekalist
List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html


_______________________________________________
Wekalist mailing list
Send posts to: [hidden email]
List info and subscription status: https://list.waikato.ac.nz/mailman/listinfo/wekalist
List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html
Reply | Threaded
Open this post in threaded view
|

Re: image filter - preprocess

Eibe Frank-2
Administrator
Yes, you can. For example, on my computer, the following file is processed correctly with those filters:

@relation butterfly_vs_owl
@attribute filename string
@attribute class {BUTTERFLY,OWL}
@data
/Users/eibe/wekafiles/packages/imageFilters/data/butterfly_vs_owl/mno001.jpg,BUTTERFLY

Cheers,
Eibe

> On 7/09/2017, at 3:33 PM, Desai Ankit <[hidden email]> wrote:
>
> Can we supply filepath in place of filename? In arff?
>
> On 07-Sep-2017 8:56 AM, "Eibe Frank" <[hidden email]> wrote:
> Not sure what's going on. You may have to try to debug this yourself.
>
> Cheers,
> Eibe
>
> On Thu, 7 Sep 2017 at 3:24 PM, Desai Ankit <[hidden email]> wrote:
> No.
>
> On 07-Sep-2017 8:53 AM, "Eibe Frank" <[hidden email]> wrote:
> Are their any other error messages in the log? Or in the console?
>
> Cheers,
> Eibe
>
> On Thu, 7 Sep 2017 at 3:16 PM, Desai Ankit <[hidden email]> wrote:
> All images are .jpg and arff file has two attributes first is filename as string and 2nd is numeric class. File path i have supplied as an argument -D option.
>
>
> On 07-Sep-2017 8:42 AM, "Eibe Frank" <[hidden email]> wrote:
> Have you checked the file paths in your ARFF file? Also, which file type are you using for your images?
>
> Cheers,
> Eibe
>
> On Thu, 7 Sep 2017 at 12:22 AM, Desai Ankit <[hidden email]> wrote:
> Hi all,
>
> I am using package: imageFilters
>
> when I am runing the inbuild datasets like butterfly_vs_owl its works fine.
>
> but when I tried to load my images with same configuration as it was in inbuild dataset. it generate following error upon applying filter mentioned in error. (rather I tried all filters but its the same error that i get)
>
> 12:13:04: Command: weka.filters.unsupervised.instance.imagefilter.AutoColorCorrelogramFilter -D /path/to/folder/300_250_weka
> 12:13:09: Problem filtering instances: null
>
> what could be the possible cause of this error?
>
> Please help.
>
> Regads,
> --
> Ankit Desai
> desaiankitb.tk
> http://ankitbdesai.blogspot.in/ 
> _______________________________________________
> Wekalist mailing list
> Send posts to: [hidden email]
> List info and subscription status: https://list.waikato.ac.nz/mailman/listinfo/wekalist
> List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html
>
> _______________________________________________
> Wekalist mailing list
> Send posts to: [hidden email]
> List info and subscription status: https://list.waikato.ac.nz/mailman/listinfo/wekalist
> List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html
>
>
> _______________________________________________
> Wekalist mailing list
> Send posts to: [hidden email]
> List info and subscription status: https://list.waikato.ac.nz/mailman/listinfo/wekalist
> List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html
>
> _______________________________________________
> Wekalist mailing list
> Send posts to: [hidden email]
> List info and subscription status: https://list.waikato.ac.nz/mailman/listinfo/wekalist
> List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html
>
> _______________________________________________
> Wekalist mailing list
> Send posts to: [hidden email]
> List info and subscription status: https://list.waikato.ac.nz/mailman/listinfo/wekalist
> List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html
>
> _______________________________________________
> Wekalist mailing list
> Send posts to: [hidden email]
> List info and subscription status: https://list.waikato.ac.nz/mailman/listinfo/wekalist
> List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html
>
> _______________________________________________
> Wekalist mailing list
> Send posts to: [hidden email]
> List info and subscription status: https://list.waikato.ac.nz/mailman/listinfo/wekalist
> List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html

_______________________________________________
Wekalist mailing list
Send posts to: [hidden email]
List info and subscription status: https://list.waikato.ac.nz/mailman/listinfo/wekalist
List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html
Reply | Threaded
Open this post in threaded view
|

Re: image filter - preprocess

mashwani15
In reply to this post by Desai Ankit
"is this problem is solved.... please help..



--
Sent from: https://weka.8497.n7.nabble.com/
_______________________________________________
Wekalist mailing list
Send posts to: [hidden email]
To subscribe, unsubscribe, etc., visit https://list.waikato.ac.nz/mailman/listinfo/wekalist
List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html
Reply | Threaded
Open this post in threaded view
|

Re: image filter - preprocess

Eibe Frank-3
Did you run into a problem with the imageFilters? They seem to work as expected whenever I use them.

Cheers,
Eibe

On Tue, Aug 6, 2019 at 5:12 PM mashwani15 <[hidden email]> wrote:
"is this problem is solved.... please help..



--
Sent from: https://weka.8497.n7.nabble.com/
_______________________________________________
Wekalist mailing list
Send posts to: [hidden email]
To subscribe, unsubscribe, etc., visit https://list.waikato.ac.nz/mailman/listinfo/wekalist
List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html

_______________________________________________
Wekalist mailing list
Send posts to: [hidden email]
To subscribe, unsubscribe, etc., visit https://list.waikato.ac.nz/mailman/listinfo/wekalist
List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html