cannot launch weka 3.8 on win10

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

cannot launch weka 3.8 on win10

milk
I installed the weka 3.8 with JVM bundle at first but cannot open it. then I installed the standalone edition and the jvm14 and 8 respectively with environment configuration,but nothing changed. when stating with console, it starts to 
update and stop again.  I paste the screen captures as below.  all in all. how can I launch weka? thanks for help. 

 PS: is 3.9 less stable than 3.8 and so on as 3.11 less than 3.10 or 3.7 less than 3.6? 




_______________________________________________
Wekalist mailing list -- [hidden email]
Send posts to [hidden email]
To unsubscribe send an email to [hidden email]
To subscribe, unsubscribe, etc., visit https://list.waikato.ac.nz/postorius/lists/wekalist.list.waikato.ac.nz
List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html

IMG_20200614_111007.jpg (4M) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: cannot launch weka 3.8 on win10

Michael Hall


> On Jun 14, 2020, at 5:45 AM, liumaokai <[hidden email]> wrote:
>
> I installed the weka 3.8 with JVM bundle at first but cannot open it. then I installed the standalone edition and the jvm14 and 8 respectively with environment configuration,but nothing changed. when stating with console, it starts to
> update and stop again.  I paste the screen captures as below.  all in all. how can I launch weka? thanks for help.
>
>  PS: is 3.9 less stable than 3.8 and so on as 3.11 less than 3.10 or 3.7 less than 3.6?
>

You might be better off with actual support people responding but I think a usual suggestion if you are trying a new release is to eliminate any possible package conflicts, if you are using any packages. I don’t remember exactly how they recommend to do that. In your java user wekafiles directory you could temporarily move the packages directory I think would be one.

For releases I believe Weka makes two different branches available. A stable production and a new feature development.  Currently 3.8 is the production and 3.9 the development.
_______________________________________________
Wekalist mailing list -- [hidden email]
Send posts to [hidden email]
To unsubscribe send an email to [hidden email]
To subscribe, unsubscribe, etc., visit https://list.waikato.ac.nz/postorius/lists/wekalist.list.waikato.ac.nz
List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html
Reply | Threaded
Open this post in threaded view
|

Re: cannot launch weka 3.8 on win10

Peter Reutemann
In reply to this post by milk
> I installed the weka 3.8 with JVM bundle at first but cannot open it. then I installed the standalone edition and the jvm14 and 8 respectively with environment configuration,but nothing changed. when stating with console, it starts to
> update and stop again.  I paste the screen captures as below.  all in all. how can I launch weka? thanks for help.

Can you access sourceforge, which hosts the Weka packages, through a browser?
https://weka.sourceforge.io/packageMetaData/

You could try starting in offline mode or using the backup package URL:
https://www.cs.waikato.ac.nz/ml/weka/packageMetaDataTemporary/

For details on package management check the following wiki article:
https://waikato.github.io/weka-wiki/packages/manager/

Cheers, Peter
--
Peter Reutemann
Dept. of Computer Science
University of Waikato, NZ
+64 (7) 858-5174
http://www.cms.waikato.ac.nz/~fracpete/
http://www.data-mining.co.nz/
_______________________________________________
Wekalist mailing list -- [hidden email]
Send posts to [hidden email]
To unsubscribe send an email to [hidden email]
To subscribe, unsubscribe, etc., visit https://list.waikato.ac.nz/postorius/lists/wekalist.list.waikato.ac.nz
List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html
Reply | Threaded
Open this post in threaded view
|

Re: cannot launch weka 3.8 on win10

Michael Hall


> On Jun 15, 2020, at 7:51 PM, Peter Reutemann <[hidden email]> wrote:
>
>> I installed the weka 3.8 with JVM bundle at first but cannot open it. then I installed the standalone edition and the jvm14 and 8 respectively with environment configuration,but nothing changed. when stating with console, it starts to
>> update and stop again.  I paste the screen captures as below.  all in all. how can I launch weka? thanks for help.
>
> Can you access sourceforge, which hosts the Weka packages, through a browser?
> https://weka.sourceforge.io/packageMetaData/
>
> You could try starting in offline mode or using the backup package URL:
> https://www.cs.waikato.ac.nz/ml/weka/packageMetaDataTemporary/
>
> For details on package management check the following wiki article:
> https://waikato.github.io/weka-wiki/packages/manager/
>
> Cheers, Peter

If it was just unable to network reach the package repository maybe trying again later could work.
I think it can be unclear whether that is the case or it failed trying to load a package.

_______________________________________________
Wekalist mailing list -- [hidden email]
Send posts to [hidden email]
To unsubscribe send an email to [hidden email]
To subscribe, unsubscribe, etc., visit https://list.waikato.ac.nz/postorius/lists/wekalist.list.waikato.ac.nz
List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html
Reply | Threaded
Open this post in threaded view
|

Re: cannot launch weka 3.8 on win10

Peter Reutemann
> If it was just unable to network reach the package repository maybe trying again later could work.
> I think it can be unclear whether that is the case or it failed trying to load a package.

The download of the package information stopped at just 114KB (of
several MB), according to the screenshot. That looks like the
connection got dropped.
Hence, the suggestions of starting with the package manager in offline
mode or using a different mirror.

Based on the OPs email/screenshot, I presume OP is located in China.
From what I recall, access to sf.net from China was patchy in the
past.

Cheers, Peter
--
Peter Reutemann
Dept. of Computer Science
University of Waikato, NZ
+64 (7) 858-5174
http://www.cms.waikato.ac.nz/~fracpete/
http://www.data-mining.co.nz/
_______________________________________________
Wekalist mailing list -- [hidden email]
Send posts to [hidden email]
To unsubscribe send an email to [hidden email]
To subscribe, unsubscribe, etc., visit https://list.waikato.ac.nz/postorius/lists/wekalist.list.waikato.ac.nz
List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html
Reply | Threaded
Open this post in threaded view
|

Re: cannot launch weka 3.8 on win10

Michael Hall


> On Jun 15, 2020, at 8:09 PM, Peter Reutemann <[hidden email]> wrote:
>
>> If it was just unable to network reach the package repository maybe trying again later could work.
>> I think it can be unclear whether that is the case or it failed trying to load a package.
>
> The download of the package information stopped at just 114KB (of
> several MB), according to the screenshot. That looks like the
> connection got dropped.
> Hence, the suggestions of starting with the package manager in offline
> mode or using a different mirror.
>
> Based on the OPs email/screenshot, I presume OP is located in China.
> From what I recall, access to sf.net from China was patchy in the
> past.
>

Useful to know. The size of the package information isn’t dependent on how many packages are installed?
_______________________________________________
Wekalist mailing list -- [hidden email]
Send posts to [hidden email]
To unsubscribe send an email to [hidden email]
To subscribe, unsubscribe, etc., visit https://list.waikato.ac.nz/postorius/lists/wekalist.list.waikato.ac.nz
List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html
Reply | Threaded
Open this post in threaded view
|

Re: cannot launch weka 3.8 on win10

Peter Reutemann
> > The download of the package information stopped at just 114KB (of
> > several MB), according to the screenshot. That looks like the
> > connection got dropped.
> > Hence, the suggestions of starting with the package manager in offline
> > mode or using a different mirror.
> >
> > Based on the OPs email/screenshot, I presume OP is located in China.
> > From what I recall, access to sf.net from China was patchy in the
> > past.
> >
>
> Useful to know. The size of the package information isn’t dependent on how many packages are installed?

No. The package manager, when first starting (or later on after a
certain interval), refreshes its cache of available packages that get
displayed in the user interface. The download of that package
information seems to hang for some reason.

Cheers, Peter
--
Peter Reutemann
Dept. of Computer Science
University of Waikato, NZ
+64 (7) 858-5174
http://www.cms.waikato.ac.nz/~fracpete/
http://www.data-mining.co.nz/
_______________________________________________
Wekalist mailing list -- [hidden email]
Send posts to [hidden email]
To unsubscribe send an email to [hidden email]
To subscribe, unsubscribe, etc., visit https://list.waikato.ac.nz/postorius/lists/wekalist.list.waikato.ac.nz
List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html