Weka Server - supplied test option

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Weka Server - supplied test option

alessandroBalestrucci
Hello everybody,

I want to expose the problem I have with the use of Weka Server.
I am able to run (remotely) the weka server on port 8085 and to use it for
classification tasks.

The problem is on the "Test options".
If I use "Use training set", or "Cross-validation", or "Percentage split",
everything works fine.

When I am using/selecting as "Test options" the "Supplied test set" errors
are shown.

I tried both of the available 2 ways. In the following the error.
1) by setting a "test file" in my local machine (defult of weka i.e.,
segment-test.arff). Then, "Run on Server", then on my host:port it's shown
"Last execution failed". Here the log obtained by clicking on the
"TaskName".
@@@ Log messages:

2021-03-31 20:53:29: J48-TestSet---2078cf59-8ccf-4f4a-980f-e7bca9fb0175 -
Starting task "J48-TestSet---2078cf59-8ccf-4f4a-980f-e7bca9fb0175"
(172.19.2.100:8085)
2021-03-31 20:53:29: J48-TestSet---2078cf59-8ccf-4f4a-980f-e7bca9fb0175 -
The test data file '/data/work/weka/weka-3-9-5/C:/Program
Files/Weka-3-9/data/segment-test.arff' does not seem to be available to the
server.
java.lang.Exception: The test data file
'/data/work/weka/weka-3-9-5/C:/Program
Files/Weka-3-9/data/segment-test.arff' does not seem to be available to the
server.
        at
weka.gui.explorer.ClassifierPanelRemoteLauncher$SeparateTestSetTask.execute(ClassifierPanelRemoteLauncher.java:923)
        at weka.server.WekaServer$3.run(WekaServer.java:675)
        at
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
        at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
        at java.lang.Thread.run(Thread.java:748)

So the test file is not sent but it seems that weka on the server is looking
for the file (I don't know why the path is merged server+local). It's worth
to notice that by executing the whole task locally it works.

2) by setting an "URL"
(https://storm.cis.fordham.edu/~gweiss/data-mining/weka-data/segment-test.arff)
in such a case an error dialog is shown with the message "Problem evaluating
classifier- see log".
The log is the following:
20:39:34: [RemoteExecutor] Starting remote execution...
20:39:34: [RemoteExecutor] Started remote execution of
weka.classifiers.trees.J48
20:39:34: [RemoteExecutor] Command: weka.classifiers.trees.J48 -C 0.25 -M 2
20:39:34: [RemoteExecutor] null

Let me stress the fact that on the server nothing starts or shown on cli. I
tried to perform the same task locally (via URL) and like before it works.

A related (marginal) issue is the fact that if a test set is stored on
Google Drive (given the permission to use it to anyone has the link); the
link does not work.

So there is a problem on the "Supplied test set".
Can anyone help me to solve this issue please?





--
Sent from: https://weka.8497.n7.nabble.com/
_______________________________________________
Wekalist mailing list -- [hidden email]
Send posts to [hidden email]
To unsubscribe send an email to [hidden email]
To subscribe, unsubscribe, etc., visit https://list.waikato.ac.nz/postorius/lists/wekalist.list.waikato.ac.nz
List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html