Weka 3.8/3.9 stuck on Blue Logo in Win10 with Java 8 (JRE 1.8.0)

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Weka 3.8/3.9 stuck on Blue Logo in Win10 with Java 8 (JRE 1.8.0)

Julian_N0843030
Sir, As titled as subject. Since I had a good time with KVliad package installation for a few weeks before half year, I've experienced this Weka blue logo hung issue over Win10 PC since then. I tried re-installation through Weka 3.8 to weka-3-9-0-x64.exe but issue was not gone. The file C:\Users\Julian\wekafiles\installedPackageCache.ser was removed, Jave 8 in jre1.8.0_271 is updated, and restarted Win10 couple times, but Weka blue logo and console still show the error message as below. What else can I do to run Weka under Win10? Or I need to run Weka in a VM under Win10? 2020-12-09 06:41:27 weka.gui.GUIChooserApp main INFO: Logging started Exception in thread "main" java.lang.InternalError: Failed to invoke main method weka.gui.SplashWindow.invokeMain(SplashWindow.java:308) weka.gui.GUIChooser.main(GUIChooser.java:92) at weka.gui.SplashWindow.invokeMain(SplashWindow.java:308) at weka.gui.GUIChooser.main(GUIChooser.java:92) Caused by: java.lang.reflect.InvocationTargetException at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source) at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source) at java.lang.reflect.Method.invoke(Unknown Source) at weka.gui.SplashWindow.invokeMain(SplashWindow.java:306) ... 1 more Caused by: java.lang.IllegalStateException: java.io.IOException: Unable to lock store within 5 seconds at weka.core.Settings.(Settings.java:134) at weka.gui.LookAndFeel.setLookAndFeel(LookAndFeel.java:147) at weka.gui.GUIChooserApp.main(GUIChooserApp.java:1747) ... 6 more Caused by: java.io.IOException: Unable to lock store within 5 seconds at weka.core.metastore.XMLFileBasedMetaStore.lockStore(XMLFileBasedMetaStore.java:234) at weka.core.metastore.XMLFileBasedMetaStore.establishStoreHome(XMLFileBasedMetaStore.java:84) at weka.core.metastore.XMLFileBasedMetaStore.getEntry(XMLFileBasedMetaStore.java:140) at weka.core.Settings.loadSettings(Settings.java:84) at weka.core.Settings.(Settings.java:132) ... 8 more

Sent from the WEKA mailing list archive at Nabble.com.

_______________________________________________
Wekalist mailing list -- [hidden email]
Send posts to [hidden email]
To unsubscribe send an email to [hidden email]
To subscribe, unsubscribe, etc., visit https://list.waikato.ac.nz/postorius/lists/wekalist.list.waikato.ac.nz
List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html
Reply | Threaded
Open this post in threaded view
|

Re: Weka 3.8/3.9 stuck on Blue Logo in Win10 with Java 8 (JRE 1.8.0)

Michael Hall


> On Dec 8, 2020, at 5:53 PM, Julian_N0843030 <[hidden email]> wrote:
> weka.gui.LookAndFeel.setLookAndFeel(LookAndFeel.java:147) at weka.gui.GUIChooserApp.main(GUIChooserApp.java:1747) ... 6 more Caused by: java.io.IOException: Unable to lock store within 5 seconds at weka.core.metastore.XMLFileBasedMetaStore.lockStore(XMLFileBasedMetaStore.java:234)  at weka.core.metastore.XMLFileBasedMetaStore.establishStoreHome(XMLFileBasedMetaStore.java:84) at weka.core.metastore.XMLFileBasedMetaStore.getEntry(XMLFileBasedMetaStore.java:140) at weka.core.Settings.loadSettings(Settings.java:84) at weka.core.Settings.(Settings.java:132) ... 8 more

Same thing?
https://weka.8497.n7.nabble.com/Hang-in-launch-OS-X-td44871.html
_______________________________________________
Wekalist mailing list -- [hidden email]
Send posts to [hidden email]
To unsubscribe send an email to [hidden email]
To subscribe, unsubscribe, etc., visit https://list.waikato.ac.nz/postorius/lists/wekalist.list.waikato.ac.nz
List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html
Reply | Threaded
Open this post in threaded view
|

Re: Weka 3.8/3.9 stuck on Blue Logo in Win10 with Java 8 (JRE 1.8.0)

Julian_N0843030
Michael,
I appreciate your immediate response and located exactly the same issue for
my reference.
Yes, my Win10-Weka-3.9 symptom is the same as this Weka-3.8.2-osX. After
removing .Lock file from \user\wekafiles\wekaMetaStore, Weka 3.9 launched
again.
I'm closing this issue with great thanks to you.

<https://weka.8497.n7.nabble.com/file/t7281/Hang_on_Weka_Logo_in_launch_OS_X.jpg>



--
Sent from: https://weka.8497.n7.nabble.com/
_______________________________________________
Wekalist mailing list -- [hidden email]
Send posts to [hidden email]
To unsubscribe send an email to [hidden email]
To subscribe, unsubscribe, etc., visit https://list.waikato.ac.nz/postorius/lists/wekalist.list.waikato.ac.nz
List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html