Problems with date attributes (bug?)

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Problems with date attributes (bug?)

CelestinoXP
Hi,
I am trying to classify date attributes, but I have encountered a new problem. After having discovered a problem with a package that crashed Weka, now the date attribute does not order the values correctly. Is it because there are "empty / unknown" values with a symbol "?" in the dataset? Together I send an image and the dataset for analysis.

Cheers,
Celestino Laranjeira.

_______________________________________________
Wekalist mailing list -- [hidden email]
Send posts to: To unsubscribe send an email to [hidden email]
To subscribe, unsubscribe, etc., visit
https://list.waikato.ac.nz/postorius/lists/wekalist.list.waikato.ac.nz
List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html

weka_error_sorting_values_by_data.PNG (51K) Download Attachment
Dataset_Equipas_Portugal.arff (22K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Problems with date attributes (bug?)

Peter Reutemann
> I am trying to classify date attributes, but I have encountered a new problem. After having discovered a problem with a package that crashed Weka, now the date attribute does not order the values correctly. Is it because there are "empty / unknown" values with a symbol "?" in the dataset? Together I send an image and the dataset for analysis.

That must be a recent regression, as the sorting works as expected in
3.6.10 and 3.7.11, but not 3.8.1 (and later).

Cheers, Peter
--
Peter Reutemann
Dept. of Computer Science
University of Waikato, NZ
+64 (7) 858-5174
http://www.cms.waikato.ac.nz/~fracpete/
http://www.data-mining.co.nz/
_______________________________________________
Wekalist mailing list -- [hidden email]
Send posts to: To unsubscribe send an email to [hidden email]
To subscribe, unsubscribe, etc., visit
https://list.waikato.ac.nz/postorius/lists/wekalist.list.waikato.ac.nz
List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html
Reply | Threaded
Open this post in threaded view
|

Re: Problems with date attributes (bug?)

CelestinoXP
In reply to this post by CelestinoXP
I said I wanted to classify the dates, but I was wrong. I wanted to say that
I want to sort the dates in ascending order.

(Google translator, sometimes creates confusion, lool)



--
Sent from: https://weka.8497.n7.nabble.com/
_______________________________________________
Wekalist mailing list -- [hidden email]
Send posts to: To unsubscribe send an email to [hidden email]
To subscribe, unsubscribe, etc., visit
https://list.waikato.ac.nz/postorius/lists/wekalist.list.waikato.ac.nz
List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html
Reply | Threaded
Open this post in threaded view
|

Re: Problems with date attributes (bug?)

Eibe Frank
In reply to this post by Peter Reutemann
It seems that the problem is simply the definition of the date attribute in the ARFF file. It is

  @attribute data date yyyy-mm-dd

It should be

  @attribute data date yyyy-MM-dd

so that the field after the first hyphen is interpreted as the month and not the minute... :-)

Cheers,
Eibe

On Sun, Feb 16, 2020 at 9:56 AM Peter Reutemann <[hidden email]> wrote:
> I am trying to classify date attributes, but I have encountered a new problem. After having discovered a problem with a package that crashed Weka, now the date attribute does not order the values correctly. Is it because there are "empty / unknown" values with a symbol "?" in the dataset? Together I send an image and the dataset for analysis.

That must be a recent regression, as the sorting works as expected in
3.6.10 and 3.7.11, but not 3.8.1 (and later).

Cheers, Peter
--
Peter Reutemann
Dept. of Computer Science
University of Waikato, NZ
+64 (7) 858-5174
http://www.cms.waikato.ac.nz/~fracpete/
http://www.data-mining.co.nz/
_______________________________________________
Wekalist mailing list -- [hidden email]
Send posts to: To unsubscribe send an email to [hidden email]
To subscribe, unsubscribe, etc., visit
https://list.waikato.ac.nz/postorius/lists/wekalist.list.waikato.ac.nz
List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html

_______________________________________________
Wekalist mailing list -- [hidden email]
Send posts to: To unsubscribe send an email to [hidden email]
To subscribe, unsubscribe, etc., visit
https://list.waikato.ac.nz/postorius/lists/wekalist.list.waikato.ac.nz
List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html
Reply | Threaded
Open this post in threaded view
|

Re: Problems with date attributes (bug?)

CelestinoXP
Thank you! Ufff, and i think weka have a bug.. lol

Thank you!

Cheers,
Celestino



--
Sent from: https://weka.8497.n7.nabble.com/
_______________________________________________
Wekalist mailing list -- [hidden email]
Send posts to: To unsubscribe send an email to [hidden email]
To subscribe, unsubscribe, etc., visit
https://list.waikato.ac.nz/postorius/lists/wekalist.list.waikato.ac.nz
List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html