Problems installing weka 3.8 and 3.9

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Problems installing weka 3.8 and 3.9

Fer137
I have years ago weka 3.7 perfectly but when I install the 3.8 or 3.9 and try
to run it only appears the circle with the logo next to these messages of
the image: What should I do?


<https://weka.8497.n7.nabble.com/file/t5190/weka_run_error.png>



--
Sent from: https://weka.8497.n7.nabble.com/
_______________________________________________
Wekalist mailing list -- [hidden email]
Send posts to: To unsubscribe send an email to [hidden email]
To subscribe, unsubscribe, etc., visit
https://list.waikato.ac.nz/postorius/lists/wekalist.list.waikato.ac.nz
List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html
Reply | Threaded
Open this post in threaded view
|

Re: Problems installing weka 3.8 and 3.9

Eibe Frank-3
You probably still have a folder named

   wekafiles

in your home folder that has old, incompatible versions of WEKA packages in it. Remove or rename this folder (or make the new WEKA  versions use a different location for storing its packages, etc., by setting the WEKA_HOME environment variable, see https://waikato.github.io/weka-wiki/packages/structure/).

Cheers,
Eibe

On Mon, Feb 17, 2020 at 3:23 PM Fer137 <[hidden email]> wrote:
I have years ago weka 3.7 perfectly but when I install the 3.8 or 3.9 and try
to run it only appears the circle with the logo next to these messages of
the image: What should I do?


<https://weka.8497.n7.nabble.com/file/t5190/weka_run_error.png>



--
Sent from: https://weka.8497.n7.nabble.com/
_______________________________________________
Wekalist mailing list -- [hidden email]
Send posts to: To unsubscribe send an email to [hidden email]
To subscribe, unsubscribe, etc., visit
https://list.waikato.ac.nz/postorius/lists/wekalist.list.waikato.ac.nz
List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html

_______________________________________________
Wekalist mailing list -- [hidden email]
Send posts to: To unsubscribe send an email to [hidden email]
To subscribe, unsubscribe, etc., visit
https://list.waikato.ac.nz/postorius/lists/wekalist.list.waikato.ac.nz
List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html
Reply | Threaded
Open this post in threaded view
|

Re: Problems installing weka 3.8 and 3.9

Michael Hall


On Feb 16, 2020, at 8:26 PM, Eibe Frank <[hidden email]> wrote:

You probably still have a folder named

   wekafiles

in your home folder that has old, incompatible versions of WEKA packages in it. Remove or rename this folder (or make the new WEKA  versions use a different location for storing its packages, etc., by setting the WEKA_HOME environment variable, see https://waikato.github.io/weka-wiki/packages/structure/).


You could also see if the weka.logs file shows any sort of java exception trace.
Something along the lines of…

head ${user.home}/wekafiles/weka.log
2020-01-25 17:43:02 weka.gui.GUIChooserApp main
INFO: Logging started
2020-01-25 17:43:03 INFO: [WekaPackageManager] Package manager using repository mirror: <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
2020-01-25 17:43:03 WARNING: [WekaPackageManager] The repository meta data mirror file seems to be unavailable (no protocol: <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">)
2020-01-25 17:43:03 weka.gui.GenericObjectEditor registerEditors
INFO: ---Registering Weka Editors---
Did not find variable R_HOME in Java cache or process environment.
Setting R_HOME to /Library/Frameworks/R.framework/Resources
Did not find variable R_LIBS_USER in Java cache or process environment.


_______________________________________________
Wekalist mailing list -- [hidden email]
Send posts to: To unsubscribe send an email to [hidden email]
To subscribe, unsubscribe, etc., visit
https://list.waikato.ac.nz/postorius/lists/wekalist.list.waikato.ac.nz
List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html
Reply | Threaded
Open this post in threaded view
|

Re: Problems installing weka 3.8 and 3.9

Fer137
In reply to this post by Fer137
It works! Thank you.



--
Sent from: https://weka.8497.n7.nabble.com/
_______________________________________________
Wekalist mailing list -- [hidden email]
Send posts to: To unsubscribe send an email to [hidden email]
To subscribe, unsubscribe, etc., visit
https://list.waikato.ac.nz/postorius/lists/wekalist.list.waikato.ac.nz
List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html
Reply | Threaded
Open this post in threaded view
|

Re: Problems installing weka 3.8 and 3.9

Michael Hall


> On Feb 17, 2020, at 4:31 PM, Fer137 <[hidden email]> wrote:
>
> It works! Thank you.
>

Great. Did you figure out what package had issues?
_______________________________________________
Wekalist mailing list -- [hidden email]
Send posts to: To unsubscribe send an email to [hidden email]
To subscribe, unsubscribe, etc., visit
https://list.waikato.ac.nz/postorius/lists/wekalist.list.waikato.ac.nz
List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html