Auto-weka problem

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Auto-weka problem

Andrey Sukhanov
Dear colleagues,
I have the following problem with Auto-WEKA:
"Problem running Auto-WEKA:
java.lang.RuntimeException: Error marshalling XML response"
The problem arrises in Weka 3.8.4 for both Windows 10 and Ubuntu 18.04


Best Regards,
Andrey


_______________________________________________
Wekalist mailing list -- [hidden email]
Send posts to: To unsubscribe send an email to [hidden email]
To subscribe, unsubscribe, etc., visit
https://list.waikato.ac.nz/postorius/lists/wekalist.list.waikato.ac.nz
List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html
Reply | Threaded
Open this post in threaded view
|

Re: Auto-weka problem

Joshua Wojnas
I had that problem I installed the development release and it worked the stable of weka doesn't have Java ee components. Since Java was built in it doesn't look if you do as far as I known. But mine works and you can try the auto weka data sets to try it quickly. Tell me if it works for you.

On Tue, Jan 14, 2020, 5:49 PM Andrey Sukhanov <[hidden email]> wrote:
Dear colleagues,
I have the following problem with Auto-WEKA:
"Problem running Auto-WEKA:
java.lang.RuntimeException: Error marshalling XML response"
The problem arrises in Weka 3.8.4 for both Windows 10 and Ubuntu 18.04


Best Regards,
Andrey

_______________________________________________
Wekalist mailing list -- [hidden email]
Send posts to: To unsubscribe send an email to [hidden email]
To subscribe, unsubscribe, etc., visit
https://list.waikato.ac.nz/postorius/lists/wekalist.list.waikato.ac.nz
List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html

_______________________________________________
Wekalist mailing list -- [hidden email]
Send posts to: To unsubscribe send an email to [hidden email]
To subscribe, unsubscribe, etc., visit
https://list.waikato.ac.nz/postorius/lists/wekalist.list.waikato.ac.nz
List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html
Reply | Threaded
Open this post in threaded view
|

Re: Auto-weka problem

Andrey Sukhanov
Nope, I installed 3.9.4 (developer version), but the problem is still there...I tried the auto-generated dataset

ср, 15 янв. 2020 г. в 10:52, Joshua Wojnas <[hidden email]>:
I had that problem I installed the development release and it worked the stable of weka doesn't have Java ee components. Since Java was built in it doesn't look if you do as far as I known. But mine works and you can try the auto weka data sets to try it quickly. Tell me if it works for you.

On Tue, Jan 14, 2020, 5:49 PM Andrey Sukhanov <[hidden email]> wrote:
Dear colleagues,
I have the following problem with Auto-WEKA:
"Problem running Auto-WEKA:
java.lang.RuntimeException: Error marshalling XML response"
The problem arrises in Weka 3.8.4 for both Windows 10 and Ubuntu 18.04


Best Regards,
Andrey

_______________________________________________
Wekalist mailing list -- [hidden email]
Send posts to: To unsubscribe send an email to [hidden email]
To subscribe, unsubscribe, etc., visit
https://list.waikato.ac.nz/postorius/lists/wekalist.list.waikato.ac.nz
List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html
_______________________________________________
Wekalist mailing list -- [hidden email]
Send posts to: To unsubscribe send an email to [hidden email]
To subscribe, unsubscribe, etc., visit
https://list.waikato.ac.nz/postorius/lists/wekalist.list.waikato.ac.nz
List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html

_______________________________________________
Wekalist mailing list -- [hidden email]
Send posts to: To unsubscribe send an email to [hidden email]
To subscribe, unsubscribe, etc., visit
https://list.waikato.ac.nz/postorius/lists/wekalist.list.waikato.ac.nz
List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html
Reply | Threaded
Open this post in threaded view
|

Re: Auto-weka problem

Eibe Frank
Currently, Auto-WEKA does not work with Java 11, which is the version of Java that is now bundled with WEKA distributions and used to run WEKA by default. With the latest WEKA installers (i.e., the ones for 3.8.4 and 3.9.4), a Zulu Java 11 JVM is installed in the directory that contains the WEKA program and is used to run WEKA.

To use Auto-WEKA you should use Java 8 (9 and 10 may also work). Install Java 8 on your system, make it the default JVM, and double-click on weka.jar (or similar) to run WEKA with the installed Java 8 (i.e., do not start it via the Windows program menu or similar, which will use the Zulu Java 11 JVM).

Cheers,
Eibe

On Wed, Jan 15, 2020 at 9:23 PM Andrey Sukhanov <[hidden email]> wrote:
Nope, I installed 3.9.4 (developer version), but the problem is still there...I tried the auto-generated dataset

ср, 15 янв. 2020 г. в 10:52, Joshua Wojnas <[hidden email]>:
I had that problem I installed the development release and it worked the stable of weka doesn't have Java ee components. Since Java was built in it doesn't look if you do as far as I known. But mine works and you can try the auto weka data sets to try it quickly. Tell me if it works for you.

On Tue, Jan 14, 2020, 5:49 PM Andrey Sukhanov <[hidden email]> wrote:
Dear colleagues,
I have the following problem with Auto-WEKA:
"Problem running Auto-WEKA:
java.lang.RuntimeException: Error marshalling XML response"
The problem arrises in Weka 3.8.4 for both Windows 10 and Ubuntu 18.04


Best Regards,
Andrey

_______________________________________________
Wekalist mailing list -- [hidden email]
Send posts to: To unsubscribe send an email to [hidden email]
To subscribe, unsubscribe, etc., visit
https://list.waikato.ac.nz/postorius/lists/wekalist.list.waikato.ac.nz
List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html
_______________________________________________
Wekalist mailing list -- [hidden email]
Send posts to: To unsubscribe send an email to [hidden email]
To subscribe, unsubscribe, etc., visit
https://list.waikato.ac.nz/postorius/lists/wekalist.list.waikato.ac.nz
List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html
_______________________________________________
Wekalist mailing list -- [hidden email]
Send posts to: To unsubscribe send an email to [hidden email]
To subscribe, unsubscribe, etc., visit
https://list.waikato.ac.nz/postorius/lists/wekalist.list.waikato.ac.nz
List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html

_______________________________________________
Wekalist mailing list -- [hidden email]
Send posts to: To unsubscribe send an email to [hidden email]
To subscribe, unsubscribe, etc., visit
https://list.waikato.ac.nz/postorius/lists/wekalist.list.waikato.ac.nz
List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html
Reply | Threaded
Open this post in threaded view
|

Re: Auto-weka problem

José Heitor
Thanks, Eibe.

Works for me - even with Zulu 8 installed on the system.

Cheers,
Jose



--
Sent from: https://weka.8497.n7.nabble.com/
_______________________________________________
Wekalist mailing list -- [hidden email]
Send posts to: To unsubscribe send an email to [hidden email]
To subscribe, unsubscribe, etc., visit
https://list.waikato.ac.nz/postorius/lists/wekalist.list.waikato.ac.nz
List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html