Why do I ge this error when Im trying to load a file?

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Why do I ge this error when Im trying to load a file?

MAAYAN
I hope you can help me please.

When Im trying to load a cvs file to weka it gets me this error:
<http://weka.8497.n7.nabble.com/file/t6735/%E2%80%8F%E2%80%8F%D7%9C%D7%9B%D7%99%D7%93%D7%94.png>

Thank you!!



--
Sent from: http://weka.8497.n7.nabble.com/
_______________________________________________
Wekalist mailing list
Send posts to: [hidden email]
To subscribe, unsubscribe, etc., visit https://list.waikato.ac.nz/mailman/listinfo/wekalist
List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html
Reply | Threaded
Open this post in threaded view
|

Re: Why do I ge this error when Im trying to load a file?

Eibe Frank-3
WEKA's CSV loader has somewhat non-standard behaviour. The main issue is often quoting.

For example, the following content of a CSV file will not work:

first_column,second_column
a "quote",more text

Quote characters must enclose the entire field. Here, in the first field, there are two characters before the first quote.

Similarly, the following will not work either because of the space character after the comma:

first_column,second_column
a, "quote"

Quoting the entire field can be used to work around this. The following will work:

first_column,second_column
'a "quote"',more text

This works because two different types of quotes are used. In most cases, you will need to use quoting and also "escape" quote characters that occur in the field using backslash characters. Here is an example:

first_column,second_column
"a \"quote\"",more text

Escaping with a backslash character is how nested quotes are dealt with in general in WEKA. Unfortunately, that is not a common strategy among programs that process CSV files.

Cheers,
Eibe








Cheers,
Eibe


On Sat, Dec 22, 2018 at 3:34 PM MAAYAN <[hidden email]> wrote:
I hope you can help me please.

When Im trying to load a cvs file to weka it gets me this error:
<http://weka.8497.n7.nabble.com/file/t6735/%E2%80%8F%E2%80%8F%D7%9C%D7%9B%D7%99%D7%93%D7%94.png>

Thank you!!



--
Sent from: http://weka.8497.n7.nabble.com/
_______________________________________________
Wekalist mailing list
Send posts to: [hidden email]
To subscribe, unsubscribe, etc., visit https://list.waikato.ac.nz/mailman/listinfo/wekalist
List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html

_______________________________________________
Wekalist mailing list
Send posts to: [hidden email]
To subscribe, unsubscribe, etc., visit https://list.waikato.ac.nz/mailman/listinfo/wekalist
List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html