Quantcast

WEKA doesn't launch under Vista

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

WEKA doesn't launch under Vista

Petroski, Greg
I have Weka 3.6.2 installed under Windows Vista 64-bit with 12mb of memory and JAVA v6. When I launch Weka I get a brief flash of what looks like a old DOS window and then nothing. Can someone advise me on how to correct this problem.

Greg Petroski, PhD
School of Medicine
University of Missouri-Columbia
Columbia, Mo.  65202 USA



_______________________________________________
Wekalist mailing list
Send posts to: [hidden email]
List info and subscription status: https://list.scms.waikato.ac.nz/mailman/listinfo/wekalist
List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: WEKA doesn't launch under Vista

Ashwin Ittoo
Petroski, Greg wrote:
> I have Weka 3.6.2 installed under Windows Vista 64-bit with 12mb of memory and JAVA v6. When I launch Weka I get a brief flash of what looks like a old DOS window and then nothing. Can someone advise me on how to correct this problem.
>
> Greg Petroski, PhD
> School of Medicine
> University of Missouri-Columbia
> Columbia, Mo.  65202 USA
>
>
>  
I have no experience with vista on 64 bit machines, but  I think you can
try running from the "command-line"
-fire the command prompt (i.e. Run->cmd)
-go the the weka directory (use cd to chagne directory)
-launch weka by typing "java -jar weka.jar" (replace weka.jar accordinly)

> ------------------------------------------------------------------------
>
> _______________________________________________
> Wekalist mailing list
> Send posts to: [hidden email]
> List info and subscription status: https://list.scms.waikato.ac.nz/mailman/listinfo/wekalist
> List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html
>  


_______________________________________________
Wekalist mailing list
Send posts to: [hidden email]
List info and subscription status: https://list.scms.waikato.ac.nz/mailman/listinfo/wekalist
List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RE: WEKA doesn't launch under Vista [Sec: UNCLASSIFIED]

Gosse, Michelle
In reply to this post by Petroski, Greg
I think you may have the same problem I encountered with Windows 7 (I could see what looked like a DOS window load semi-transparently for about a second and then it disappeared), and I managed to get past the problem yesterday, thanks to the suggestions here. :)

There were two problems that I had to fix - 1. Outdated Java version and 2. Windows 7 won't run batch files.

I had to download a freeware .bat to .exe converter, to get around the Windows 7 incompatibility with batch files (when I ran the troubleshooter, it had the path to the .bat file with a comment that it needed an executable). This will create a new file, which has a .exe extension, in the same directory as your .bat file. Because I like the console, I did the conversion on the console-loading .bat.

Finally, run the .exe and not the .bat file.  The first time I did this, Weka unpacked all its files appropriately, then started the console window. I never saw another DOS-type window appear.

I don't know if this is important to you, but Windows 7 installed Weka into my Program files(86) directory rather than Program files, which is where it puts non-64-bit programs. I don't know if Vista has this program installation feature.

I know you're using a different operating system to me, but perhaps there is a similar issue with Vista? I've never used that operating system, having gone straight from XP (no issues with Weka there) to 7.

Cheers
Michelle


-----Original Message-----
From: [hidden email] [mailto:[hidden email]] On Behalf Of Petroski, Greg
Sent: Wednesday, 31 March 2010 5:50 AM
To: '[hidden email]'
Subject: [Wekalist] WEKA doesn't launch under Vista

I have Weka 3.6.2 installed under Windows Vista 64-bit with 12mb of memory and JAVA v6. When I launch Weka I get a brief flash of what looks like a old DOS window and then nothing. Can someone advise me on how to correct this problem.

Greg Petroski, PhD
School of Medicine
University of Missouri-Columbia
Columbia, Mo.  65202 USA



**********************************************************************
This email and any files transmitted with it are confidential and
intended solely for the use of the individual or entity to whom they
are addressed. If you have received this email in error please notify
the system manager.

This footnote also confirms that this email message has been swept by
MIMEsweeper for the presence of computer viruses.

www.clearswift.com
**********************************************************************





_______________________________________________
Wekalist mailing list
Send posts to: [hidden email]
List info and subscription status: https://list.scms.waikato.ac.nz/mailman/listinfo/wekalist
List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RE: WEKA doesn't launch under Vista [Sec: UNCLASSIFIED]

Petroski, Greg
I think Vista 64 has the same issue

________________________________________
From: [hidden email] [[hidden email]] On Behalf Of Gosse, Michelle [[hidden email]]
Sent: Tuesday, March 30, 2010 2:01 PM
To: '[hidden email]'
Subject: [Wekalist] RE: WEKA doesn't launch under Vista [Sec: UNCLASSIFIED]

I think you may have the same problem I encountered with Windows 7 (I could see what looked like a DOS window load semi-transparently for about a second and then it disappeared), and I managed to get past the problem yesterday, thanks to the suggestions here. :)

There were two problems that I had to fix - 1. Outdated Java version and 2. Windows 7 won't run batch files.

I had to download a freeware .bat to .exe converter, to get around the Windows 7 incompatibility with batch files (when I ran the troubleshooter, it had the path to the .bat file with a comment that it needed an executable). This will create a new file, which has a .exe extension, in the same directory as your .bat file. Because I like the console, I did the conversion on the console-loading .bat.

Finally, run the .exe and not the .bat file.  The first time I did this, Weka unpacked all its files appropriately, then started the console window. I never saw another DOS-type window appear.

I don't know if this is important to you, but Windows 7 installed Weka into my Program files(86) directory rather than Program files, which is where it puts non-64-bit programs. I don't know if Vista has this program installation feature.

I know you're using a different operating system to me, but perhaps there is a similar issue with Vista? I've never used that operating system, having gone straight from XP (no issues with Weka there) to 7.

Cheers
Michelle


-----Original Message-----
From: [hidden email] [mailto:[hidden email]] On Behalf Of Petroski, Greg
Sent: Wednesday, 31 March 2010 5:50 AM
To: '[hidden email]'
Subject: [Wekalist] WEKA doesn't launch under Vista

I have Weka 3.6.2 installed under Windows Vista 64-bit with 12mb of memory and JAVA v6. When I launch Weka I get a brief flash of what looks like a old DOS window and then nothing. Can someone advise me on how to correct this problem.

Greg Petroski, PhD
School of Medicine
University of Missouri-Columbia
Columbia, Mo.  65202 USA



**********************************************************************
This email and any files transmitted with it are confidential and
intended solely for the use of the individual or entity to whom they
are addressed. If you have received this email in error please notify
the system manager.

This footnote also confirms that this email message has been swept by
MIMEsweeper for the presence of computer viruses.

www.clearswift.com
**********************************************************************

_______________________________________________
Wekalist mailing list
Send posts to: [hidden email]
List info and subscription status: https://list.scms.waikato.ac.nz/mailman/listinfo/wekalist
List etiquette: http://www.cs.waikato.ac.nz/~ml/weka/mailinglist_etiquette.html
Loading...